Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Oct 01, 2025 - 13:07 BST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 01, 2025 - 13:00 BST
Scheduled
As part of our 24/7 software monitoring, we’ve identified a need to update the Notify platform. This means we will be offline for up to 30 minutes today, Wednesday 1st October from 1pm (BST).
Please ensure any work in progress on Notify Cloud is saved prior to this time. If you use our mobile applications to report Safety, Environmental or Quality events, or to carry out Audits and Inspections, you will still be able to do so while Notify is offline. Your incidents will still be submitted, and any audits will be uploaded as soon as we are back online.
Thank you for your support as we continue to enhance the security of the Notify platform.
Posted Oct 01, 2025 - 11:13 BST
This scheduled maintenance affected: Notify Cloud (Website, Dashboards).