Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 07, 2026 - 19:00 BST
Scheduled
We will shortly be releasing Notify Cloud v8.3.7, a maintenance update that improves system performance and security.
This update includes: - Improved PDF export performance: Images in audit and risk assessment PDF exports will now be compressed, significantly reducing file sizes and improving export speed and reliability, particularly for audits containing large numbers of photos - Resolved: Audit PDF export error: Fixes an issue where exporting certain audits to PDF could produce an error - Resolved: Incident Creator form field: Fixes an issue where the Incident Creator form field in the template builder displayed archived incident types - Microsoft SSO enhancement: Further enhancements to authentication of users
Posted Jul 07, 2026 - 14:35 BST
This scheduled maintenance affected: Notify Cloud (Website, Dashboards).