Reporting incidents on the Web

Incident Report for Notify Technology

Resolved

This issue has now resolved.
Posted Oct 01, 2025 - 15:30 BST

Monitoring

A fix has been implemented and our team will continue to monitor this area of the platform throughout the rest of the afternoon.
Posted Oct 01, 2025 - 13:18 BST

Identified

We are aware that some customers are currently experiencing difficulties when attempting to report an incident via https://cloud.notifytechnology.com/report-an-incident/.

You can still report an incident via our Mobile App at this time.

Our team has identified the root cause and will be deploying a fix at 1:00pm (UK time) today.

Thank you for your patience while we resolve this issue.
Posted Oct 01, 2025 - 11:41 BST
This incident affected: Notify Cloud (Website).